注册 登录  
 加关注

网易博客网站关停、迁移的公告:

将从2018年11月30日00:00起正式停止网易博客运营
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

是缘是情是童真

如果你用笑脸面对 你会看见别人的笑脸

 
 
 

日志

 
 

conversion to dalvik format failed with error 1的解决办法  

2011-08-05 16:41:02|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

 在eclipse开发Android项目时出现的很多问题都可以使用Project--------->clean来轻易解决。

    但如果出现说Android库找不到,或者不小心remove了Android系统库,怎么重新添加Android系统库呢?
在eclipse里面的Java Build Path里面是没法添加例如Android 2.1这样定义好的系统库。而我尝试手动添加
SDK 文件夹里面的Android.jar,结果出现了Conversion to Dalvik format failed with error 1问题了。折腾了
一番后,很多网友都说用Project clean可以解决,但对我的情况来说,没有用处。
    在百度找到解决方法了:
    修改项目classpath文件,这让我明白了,直接从其他正常项目里面把
<!-- 注意,这个.classpath文件在eclipse工作空间的硬盘存放位置对应工程项目目录下面 -->

      <classpathentry kind="lib"   path ="自定义jar的地址" /> 
修改成

      <classpathentry kind="con" path="com.android.ide.eclipse.adt.ANDROID_FRAMEWORK"/>
这样子刷新项目,Android系统库Android 2.1回来了,那个错误也解决了。

 --------------------------------------------------------------------------------------------------------------------------

    这几天又遇到这样的问题了,但是.classpath文件里面已经包含了上面的con Path,后来在论坛
(http://www.eoeandroid.com/thread-53880-1-1.html)上找到新方法:

    project -> properties -> android label, check a target from the project build target list
<!-- 这样有时候还是不能去掉错误,这时候注意,在进入project -> properties -> android后,下面有
一个is library项,把它勾上,再点击确定错误就OK了,我的错误就是这样解决的,一开始按照上面
以及后面的方法都解决不了,最后我看到有一个is library项,把它勾上再确定试一下OK,错误没了 -->


============================================================================


附:
上网上广为流传的解决方法:conversion to dalvik format failed with error 1的解决办法

 
android低版本工程(如1.5)放到高版本环境中(如2.2)可能会上述错误,解决方法如下: 

    1、如果不修改android sdk版本,则使用project clean 命令作用于某工程即可。 (该处理方式
只是在高版本中兼容了低版本工程,未真正意义上的升级) 

    2、如果修改android sdk版本,则需要以下几个步骤: 
       1) 修改SDK 
             选择工程,build path --> configure build path ---> library 删除引用的低版本SDK, 
             然后add External JARs,选择高版本SDK,OK,保存 

       2) 修改classpath文件 

             该文件可能存在该项: <classpathentry kind="lib"   path ="你所指定的高版本的地址" 
             把她修改成<classpathentry kind="con" path="com.android.ide.eclipse.adt.ANDROID_FRAMEWORK" /> 
       3) 修改AndroidManifest.xml 
             在AndroidManifest.xml文件中,application标签后添加<uses-sdk android:minSdkVersion="3"></uses-sdk> 
       4) 修改default.properties(很重要) 
              该文件最后一行(前面没用#的)target=android-3 该成target=android-8,保存。 
       再看看你的工程和新建的android 2.2的工程结构就一样了。
  评论这张
 
阅读(7617)| 评论(1)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018